Name: rhc-worker-playbook
Summary: Red Hat connect worker for launching Ansible Runner
Version: 0.1.2
Release: 4%{?dist}
License: GPLv2+
Source: rhc-worker-playbook-0.1.2.tar.gz
%{?__python3:Requires: %{__python3}}
BuildRequires: python3-devel
BuildRequires: platform-python-pip
BuildRequires: openssl-devel
BuildRequires: c-ares-devel
BuildRequires: zlib-devel
BuildRequires: python3dist(cython)
%description
Python-based worker for Red Hat connect, used to launch Ansible playbooks via Ansible Runner.
%prep
%setup -q
%install
export GRPC_PYTHON_BUILD_WITH_CYTHON=True
export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=True
export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=True
export GRPC_PYTHON_BUILD_SYSTEM_CARES=True
export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=True
%{make_install} BUILDROOT=%{buildroot} PREFIX=%{_prefix} LIBDIR=%{_libdir} LIBEXECDIR=%{_libexecdir} PYTHON=%{__python3}
%post
%preun
%postun
%clean
rm -rf %{buildroot}
%files
%{_libexecdir}/rhc/rhc-worker-playbook.worker
%{python3_sitelib}/rhc_worker_playbook/
%{python3_sitelib}/rhc_worker_playbook*.egg-info/
%{_libdir}/rhc-worker-playbook/
%doc
%changelog