Blob Blame History Raw
Name:           python-time-machine
Version:        2.16.0
Release:        1%{?dist}
Summary:        Travel through time in your Python tests
License:        MIT
URL:            https://github.com/adamchainz/time-machine
Source:         %{url}/archive/%{version}/time-machine-%{version}.tar.gz

BuildRequires:  gcc
BuildRequires:  python3-devel

%global _description %{expand:
A Python library that allows to travel in time and freeze it as well.
Includes a test-function decorator that sets time to an arbitrary value.}

%description %_description

%package -n     python3-time-machine
Summary:        %{summary}

%description -n python3-time-machine %_description


%prep
%autosetup -p1 -n time-machine-%{version}
sed -i '/coverage/d' tests/requirements/requirements.in


%generate_buildrequires
# tox uses a pinned version of requirements/requirements.in and also uses coverage
# so we bypass it.
# This also saves us one dependency cycle as tox uses time-machine for tests.
%pyproject_buildrequires tests/requirements/requirements.in


%build
%pyproject_wheel


%install
%pyproject_install
%pyproject_save_files time_machine _time_machine


%check
%pytest -v


%files -n python3-time-machine -f %{pyproject_files}
%doc README.rst HISTORY.rst


%changelog
* Tue Oct 08 2024 Charalampos Stratakis <cstratak@redhat.com> - 2.16.0-1
- Update to 2.16.0
- Fixes: rhbz#2295579

* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.14.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

* Sat Jun 08 2024 Python Maint <python-maint@redhat.com> - 2.14.1-2
- Rebuilt for Python 3.13

* Mon Apr 22 2024 Karolina Surma <ksurma@redhat.com> - 2.14.1-1
- Update to 2.14.1

* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.13.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.13.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Fri Nov 24 2023 Miro Hrončok <miro@hroncok.cz> - 2.13.0-2
- Add support for Python 3.13.0a2+

* Fri Nov 24 2023 Miro Hrončok <miro@hroncok.cz> - 2.13.0-1
- Update to 2.13.0
- Fixes: rhbz#2239635

* Tue Aug 29 2023 Charalampos Stratakis <cstratak@redhat.com> - 2.12.0-1
- Update to 2.12.0

* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild

* Fri Jun 16 2023 Python Maint <python-maint@redhat.com> - 2.9.0-3
- Rebuilt for Python 3.12

* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

* Wed Jan 11 2023 Miro Hrončok <miro@hroncok.cz> - 2.9.0-1
- Initial import
- Fixes: rhbz#2159772