%if 0%{?fedora} || 0%{?rhel} > 7
%bcond_with python2
%bcond_without python3
%else
%bcond_without python2
%bcond_with python3
%endif
%global pypi_name sphinxcontrib-blockdiag
Name: python-%{pypi_name}
Version: 2.0.0
Release: 4%{?dist}
Summary: Sphinx "blockdiag" extension
License: BSD
URL: https://github.com/blockdiag/sphinxcontrib-blockdiag
Source0: https://files.pythonhosted.org/packages/source/s/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
BuildArch: noarch
%description
A sphinx extension for embedding block diagram using blockdiag_.
%if %{with python2}
%package -n python2-%{pypi_name}
Summary: Sphinx "blockdiag" extension
%{?python_provide:%python_provide python2-%{pypi_name}}
BuildRequires: python2-setuptools
BuildRequires: python2-devel
Requires: python2-blockdiag >= 1.5.0
Requires: python2-sphinx >= 0.6
%description -n python2-%{pypi_name}
A sphinx extension for embedding block diagram using blockdiag_.
%endif
%if %{with python3}
%package -n python3-%{pypi_name}
Summary: Sphinx "blockdiag" extension
%{?python_provide:%python_provide python3-%{pypi_name}}
BuildRequires: python3-setuptools
BuildRequires: python3-devel
Requires: python3-blockdiag >= 2.0.0
Requires: python3-sphinx >= 2.0.0
%description -n python3-%{pypi_name}
A sphinx extension for embedding block diagram using blockdiag_.
%endif
%prep
%autosetup -n %{pypi_name}-%{version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info
%build
%if %{with python2}
%py2_build
%endif
%if %{with python3}
%py3_build
%endif
%install
%if %{with python2}
%py2_install
%endif
%if 0%{with python3}
%py3_install
%endif
%if %{with python2}
%files -n python2-%{pypi_name}
%license LICENSE
%doc README.rst
%{python2_sitelib}/sphinxcontrib
%{python2_sitelib}/sphinxcontrib_blockdiag-*.egg-info
%{python2_sitelib}/sphinxcontrib_blockdiag-*.pth
%exclude %{python2_sitelib}/sphinxcontrib/tests
%endif
%if %{with python3}
%files -n python3-%{pypi_name}
%license LICENSE
%doc README.rst
%{python3_sitelib}/sphinxcontrib
%{python3_sitelib}/sphinxcontrib_blockdiag-*.egg-info
%{python3_sitelib}/sphinxcontrib_blockdiag-*.pth
%exclude %{python3_sitelib}/sphinxcontrib/tests
%endif
%changelog
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 2.0.0-2
- Rebuilt for Python 3.9
* Tue Mar 10 2020 Fabien Boucher <fboucher@redhat.com> - 2.0.0-1
- Bump to last release 2.0.0 (#1811927)
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.5-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.5.5-13
- Rebuilt for Python 3.8.0rc1 (#1748018)
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 1.5.5-12
- Rebuilt for Python 3.8
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.5-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.5-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Thu Sep 13 2018 Javier Peña <jpena@redhat.com> - 1.5.5-9
- Remove the python2 package for Fedora 30+ (bz#1627370)
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.5-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.5.5-7
- Rebuilt for Python 3.7
* Fri Feb 09 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.5.5-6
- Update Python 2 dependency declarations to new packaging standards
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.5-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.5-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 1.5.5-2
- Rebuild for Python 3.6
* Tue Sep 20 2016 Javier Peña <jpena@redhat.com> - 1.5.5-1
- Initial package.