Name: python-ncclient
Version: 0.6.16
Release: 1%{?dist}
Summary: Python library for the NETCONF protocol
# The entire source is Apache-2.0, except:
#
# Unlicense:
# - The script versioneer.py (a vendored, amalgamated copy of
# python3dist(versioneer) = 0.28 that is not packaged), and the file
# ncclient/_version.py, which was generated by it
License: Apache-2.0 AND Unlicense
URL: https://github.com/ncclient/ncclient
Source0: %{url}/archive/v%{version}/ncclient-%{version}.tar.gz
BuildArch: noarch
BuildRequires: python3-devel
# requirements.txt
BuildRequires: python3-setuptools > 0.5
BuildRequires: python3-paramiko > 1.15.0
BuildRequires: python3-lxml > 3.3.0
BuildRequires: python3-six
# test-requirements.txt
BuildRequires: python3-pytest-runner
# Skip sphinx: we do not test building the documentation
# Skip flake8; we do not run style/linting tests
# Skip pytest-cov; we do not run coverage analysis
BuildRequires: python3-pytest
%global common_description %{expand:
ncclient is a Python library that facilitates client-side scripting and
application development around the NETCONF protocol. ncclient was developed by
Shikar Bhushan.net). It is now maintained by Leonidas Poulopoulos (@leopoul)
and Einar Nilsen-Nygaard (@einarnn).
Docs: http://ncclient.readthedocs.org
PyPI: https://pypi.python.org/pypi/ncclient}
%description %{common_description}
%package -n python3-ncclient
Summary: %{summary}
%py_provides python3-ncclient
%description -n python3-ncclient %{common_description}
%package doc
Summary: Documentation and examples for python-ncclient
# Cannot build documentation because sphinx is too old:
# BuildRequires: make
# # docs/requirements.txt
# BuildRequires: python#{python3_pkgversion}-sphinx >= 3.2.0
%description doc
The python-ncclient-doc package contains detailed documentation and examples
for python-ncclient.
%prep
%autosetup -n ncclient-%{version}
%py3_shebang_fix examples
%build
%py3_build
%install
%py3_install
%check
%pytest
%files -n python3-ncclient
%license LICENSE
%{python3_sitelib}/ncclient/
%{python3_sitelib}/ncclient-%{version}-py%{python3_version}.egg-info/
%files doc
%license LICENSE
%doc Changelog
%doc NOTICE
%doc README.md
%doc README.rst
%doc examples/
%changelog
* Wed Oct 09 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.16-1
- Update to 0.6.16 (close RHBZ#2317548)
* Sun Oct 22 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.15-1
- Update to 0.6.15 (close RHBZ#2244719)
* Sun Oct 22 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.13-4
- Remove obsolete rpmlintrc
* Sun Oct 22 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.13-3
- Use a trailing slash when listing directories in files lists
* Sun Oct 22 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.13-2
- Update License to SPDX
* Mon Apr 11 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.13-1
- Update to 0.6.13 (close RHBZ#2073846)
* Mon Apr 11 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.12-5
- Drop “forge” macros, since they don’t benefit us much
* Mon Apr 11 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.12-4
- %%%%python3_pkgversion is unnecessary on EPEL8
* Mon Apr 11 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.12-3
- Reduce macro indirection in the spec file
* Sun May 30 2021 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.12-1
- Update to 0.6.12
* Sat May 29 2021 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.11-1
- Update to 0.6.11
- Drop upstreamed patches
* Wed Mar 17 2021 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.10-3
- Backport from Fedora 35 to EPEL8
* Tue Mar 16 2021 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.10-2
- Patch out BR on deprecated python3-mock
- Patch out BR on deprecated python3-nose
* Tue Mar 16 2021 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.10-1
- Update to 0.16.10
- Drop python-ncclient-0.6.9-shebangs.patch, now upstreamed
- Drop python3dist(setuptools) BR, redundant with pyproject-rpm-macros
* Tue Mar 02 2021 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.9-2
- Rebuild for fixed RHBZ#1925963 in pyproject-rpm-macros-0-38
- Enable parallel Sphinx build
* Fri Jan 1 2021 Benjamin A. Beasley <code@musicinmybrain.net> - 0.6.9-1
- Prepare for unretirement
- New upstream version 0.6.9
- Migrate from Python 2 to Python 3
- Use new macros for source URL and build/install/test sections, and drop old
macros like python_provide
- Use generated Requires and BuildRequires
- Split documentation and examples into a separate -doc subpackage
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.7-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.7-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Fri Jan 26 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.4.7-6
- Update Python 2 dependency declarations to new packaging standards
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
* Sat Aug 19 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.4.7-5
- Python 2 binary package renamed to python2-ncclient
See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.7-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.7-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.7-2
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
* Tue Mar 08 2016 Ihar Hrachyshka <ihrachys@redhat.com> 0.4.7-1.el7
- Update to 0.4.7
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Fri Dec 5 2014 Ihar Hrachyshka <ihrachys@redhat.com> - 0.4.2-2
- Added missing python-setuptools as a build dependency.
- Include documentation and examples.
- Run unit tests on build.
- Rebuild egg file.
- Added python2 macros needed for el6.
- Made python macros more specific (python -> python2).
- Made python2_sitelib file inclusion wildcard a bit more strict.
* Thu Dec 4 2014 Ihar Hrachyshka <ihrachys@redhat.com> - 0.4.2-1
- Updated to upstream 0.4.2 version
* Thu Aug 7 2014 Ihar Hrachyshka <ihrachys@redhat.com> - 0.4.1-1
- Initial package for Fedora