%if 0%{?fedora} || 0%{?rhel} >= 8
%global with_python3 1
%endif
%global pypi_name XStatic-jQuery
Name: python-%{pypi_name}
Version: 1.10.2.1
Release: 9%{?dist}.2
Summary: jQuery (XStatic packaging standard)
License: MIT
URL: http://jquery.com/
Source0: https://files.pythonhosted.org/packages/source/X/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
BuildArch: noarch
BuildRequires: web-assets-devel
%description
JavaScript library packaged for setuptools (easy_install) / pip.
This package is intended to be used by any project that needs these files.
It intentionally does not provide any extra code except some metadata
nor has any extra requirements.
%if 0%{?with_python3}
%package -n python3-%{pypi_name}
Summary: %{summary}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
Requires: python3-XStatic
#Requires: js-jquery1
%{?python_provide:%python_provide python3-%{pypi_name}}
%description -n python3-%{pypi_name}
JavaScript library packaged for setuptools (easy_install) / pip.
This package is intended to be used by any project that needs these files.
It intentionally does not provide any extra code except some metadata
nor has any extra requirements.
This package provides Python 3 build of %{pypi_name}.
%endif
%prep
%autosetup -n %{pypi_name}-%{version}
# patch to use webassets dir
#sed -i "s|^BASE_DIR = .*|BASE_DIR = '%{_jsdir}/jquery/1'|" xstatic/pkg/jquery/__init__.py
%build
%if 0%{?with_python3}
%py3_build
%endif
%install
#rm -rf %{buildroot}%{python2_sitelib}/xstatic/pkg/jquery/data/
%if 0%{?with_python3}
%py3_install
# Remove static files, already created by the python2 subpkg
#rm -rf %{buildroot}%{python3_sitelib}/xstatic/pkg/jquery/data
%endif
%if 0%{?with_python3}
%files -n python3-%{pypi_name}
%doc README.txt
%{python3_sitelib}/xstatic/pkg/jquery
%{python3_sitelib}/XStatic_jQuery-%{version}-py%{python3_version}.egg-info
%{python3_sitelib}/XStatic_jQuery-%{version}-py%{python3_version}-nspkg.pth
%endif
%changelog
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.2.1-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.2.1-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.2.1-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Mon Dec 19 2016 Miro HronĨok <mhroncok@redhat.com> - 1.10.2.1-6
- Rebuild for Python 3.6
* Thu Oct 13 2016 Jan Beran <jberan@redhat.com> - 1.10.2.1-5
- Provides a Python 3 subpackage
- depend on js-jquery1 rather than bundling its own
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10.2.1-4
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.2.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10.2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Wed Mar 12 2014 Matthias Runge <mrunge@redhat.com> - 1.10.2.1-1
- Initial package.