%global pkg ecryptfs
%global driver_version 4.18.0-305.el8
%global kernel_version 4.18.0-348.el8
%global _use_internal_dependency_generator 0
%global __find_requires /usr/lib/rpm/redhat/find-requires
%global __find_provides /usr/lib/rpm/redhat/find-provides
%global debug_package %{nil}
%global __spec_install_post \
%{?__debug_package:%{__debug_install_post}} \
%{__arch_install_post} \
%{__os_install_post} \
%{__mod_compress_install_post}
%global __mod_compress_install_post find %{buildroot}/lib/modules -type f -name \*.ko -exec xz \{\} \\;
Name: kmod-%{pkg}
Version: 4.18.0.305
Release: 1%{?dist}
Summary: Encrypted filesystem that operates on the VFS layer
License: GPLv2
URL: https://www.kernel.org/
Source0: %{pkg}-%{driver_version}.tar.xz
Patch1: 0001-ecryptfs_rename-verify-that-lower-dentries-are-still.patch
Patch2: 0002-crypto-shash-remove-shash_desc-flags.patch
Patch3: 0003-eCryptfs-fix-a-couple-type-promotion-bugs.patch
Patch4: 0004-eCryptfs-fix-permission-denied-with-ecryptfs_xattr-m.patch
Patch5: 0005-ecryptfs-fix-unlink-and-rmdir-in-face-of-underlying-.patch
Patch6: 0006-ecryptfs_lookup_interpose-lower_dentry-d_inode-is-no.patch
Patch7: 0007-ecryptfs_lookup_interpose-lower_dentry-d_parent-is-n.patch
Patch8: 0008-ecryptfs-fix-a-memory-leak-bug-in-parse_tag_1_packet.patch
Patch9: 0009-ecryptfs-fix-a-memory-leak-bug-in-ecryptfs_init_mess.patch
Patch10: 0010-ecryptfs-fix-kernel-panic-with-null-dev_name.patch
Patch11: 0011-fs-ecryptfs-remove-BUG_ON-from-crypt_scatterlist.patch
Patch9999: 9999-enable-ecryptfs.patch
ExclusiveArch: x86_64 aarch64
BuildRequires: elfutils-libelf-devel
BuildRequires: gcc
BuildRequires: kernel-rpm-macros
BuildRequires: kmod
BuildRequires: make
BuildRequires: redhat-rpm-config
BuildRequires: xz
BuildRequires: kernel-abi-stablelists = %{kernel_version}
BuildRequires: kernel-devel = %{kernel_version}
BuildRequires: kernel-devel-uname-r = %{kernel_version}.%{_arch}
Requires: kernel >= %{kernel_version}
Requires: kernel-uname-r >= %{kernel_version}.%{_arch}
Requires: kernel-modules >= %{kernel_version}
Requires: kernel-modules-uname-r >= %{kernel_version}.%{_arch}
Provides: installonlypkg(kernel-module)
Provides: kernel-modules >= %{kernel_version}.%{_arch}
Requires(post): %{_sbindir}/depmod
Requires(postun): %{_sbindir}/depmod
Requires(post): %{_sbindir}/weak-modules
Requires(postun): %{_sbindir}/weak-modules
Supplements: ecryptfs-utils
Recommends: ecryptfs-utils
%description
This package provides the required kernel module (ecryptfs) to mount devices
formatted with the Encrypted filesystem that operates on the VFS layer.
%prep
%autosetup -p1 -n %{pkg}-%{driver_version}
%build
pushd src
%{__make} -C /usr/src/kernels/%{kernel_version}.%{_arch} %{?_smp_mflags} M=$PWD modules
popd
%install
%{__install} -D -t %{buildroot}/lib/modules/%{kernel_version}.%{_arch}/extra/fs/%{pkg} src/%{pkg}.ko
# Make .ko objects temporarily executable for automatic stripping
find %{buildroot}/lib/modules -type f -name \*.ko -exec chmod u+x \{\} \+
%clean
%{__rm} -rf %{buildroot}
%post
mkdir -p %{_localstatedir}/lib/rpm-state/sig-kmods
printf '%s\n' "/lib/modules/%{kernel_version}.%{_arch}/extra/fs/%{pkg}/%{pkg}.ko.xz" >> %{_localstatedir}/lib/rpm-state/sig-kmods/weak-modules-add
%preun
mkdir -p %{_localstatedir}/lib/rpm-state/sig-kmods
rpm -ql kmod-%{pkg}-%{?epoch:%{epoch}:}%{version}-%{release}.%{_arch} | grep '/lib/modules/%{kernel_version}.%{_arch}/.*\.ko\.xz$' >> %{_localstatedir}/lib/rpm-state/sig-kmods/weak-modules-remove
%postun
if [ -f %{_localstatedir}/lib/rpm-state/sig-kmods/weak-modules-remove ]
then
modules=( $(cat %{_localstatedir}/lib/rpm-state/sig-kmods/weak-modules-remove) )
rm -f %{_localstatedir}/lib/rpm-state/sig-kmods/weak-modules-remove
rmdir --ignore-fail-on-non-empty %{_localstatedir}/lib/rpm-state/sig-kmods
printf '%s\n' "${modules[@]}" | %{_sbindir}/weak-modules --remove-modules
fi
%pretrans -p <lua>
posix.unlink("%{_localstatedir}/lib/rpm-state/sig-kmods/weak-modules-add")
posix.unlink("%{_localstatedir}/lib/rpm-state/sig-kmods/weak-modules-remove")
%posttrans
if [ -f %{_localstatedir}/lib/rpm-state/sig-kmods/weak-modules-add ]
then
modules=( $(cat %{_localstatedir}/lib/rpm-state/sig-kmods/weak-modules-add) )
rm -f %{_localstatedir}/lib/rpm-state/sig-kmods/weak-modules-add
rmdir --ignore-fail-on-non-empty %{_localstatedir}/lib/rpm-state/sig-kmods
printf '%s\n' "${modules[@]}" | %{_sbindir}/weak-modules --add-modules
fi
%files
%defattr(644,root,root,755)
/lib/modules/%{kernel_version}.%{_arch}
%license COPYING
%changelog
* Wed Jan 12 2022 Kmods SIG <sig-kmods@centosproject.org> - 4.18.0.305-1
- Switch to EL kernel source and versioning
- kABI tracking kmod package (kernel >= 4.18.0-348.el8)