%global base_name cli
%global short_name commons-%{base_name}
Name: apache-%{short_name}
Version: 1.2
Release: 13%{?dist}
Summary: Command Line Interface Library for Java
Group: Development/Libraries
License: ASL 2.0
URL: http://commons.apache.org/%{base_name}/
Source0: http://www.apache.org/dist/commons/%{base_name}/source/%{short_name}-%{version}-src.tar.gz
BuildArch: noarch
BuildRequires: java-devel >= 1:1.6.0
BuildRequires: jpackage-utils
BuildRequires: maven-local
BuildRequires: apache-commons-parent >= 26-7
# This should go away with F-17
Provides: jakarta-%{short_name} = 0:%{version}-%{release}
Obsoletes: jakarta-%{short_name} < 0:1.1-6
%description
The CLI library provides a simple and easy to use API for working with the
command line arguments and options.
%package javadoc
Summary: Javadoc for %{name}
Group: Documentation
# This should go away with F-17
Obsoletes: jakarta-%{short_name}-javadoc < 0:1.1-6
%description javadoc
This package contains the API documentation for %{name}.
%prep
%setup -q -n %{short_name}-%{version}-src
# Compatibility links
%mvn_alias "%{short_name}:%{short_name}" "org.apache.commons:%{short_name}"
%mvn_file :commons-cli %{short_name} %{name}
%build
%mvn_build
%install
%mvn_install
%files -f .mfiles
%doc LICENSE.txt NOTICE.txt README.txt RELEASE-NOTES.txt
%files javadoc -f .mfiles-javadoc
%doc LICENSE.txt NOTICE.txt
%changelog
* Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 1.2-13
- Mass rebuild 2013-12-27
* Fri Sep 20 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.2-12
- Add BuildRequires on apache-commons-parent >= 26-7
* Thu Aug 22 2013 Michal Srb <msrb@redhat.com> - 1.2-11
- Migrate away from mvn-rpmbuild (Resolves: #997473)
* Fri Jun 28 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.2-10
- Rebuild to regenerate API documentation
- Resolves: CVE-2013-1571
* Tue Feb 19 2013 Mat Booth <fedora@matbooth.co.uk> - 1.2-9
- Add missing maven-local BuildRequires
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Wed Nov 30 2011 Alexander Kurtakov <akurtako@redhat.com> 1.2-5
- Build with maven 3.
- Adapt to current guidelines.
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Tue Nov 9 2010 Chris Spike <chris.spike@arcor.de> 1.2-3
- Removed maven* BRs in favour of apache-commons-parent
- Added deprecated groupId to depmap for compatibility reasons
* Mon Oct 18 2010 Chris Spike <chris.spike@arcor.de> 1.2-2
- Removed Epoch
* Sun Oct 3 2010 Chris Spike <chris.spike@arcor.de> 1.2-1
- Rename and rebase from jakarta-commons-cli