From 7f00bd87226a953ee41efdd55c57cc0011bbc32d Mon Sep 17 00:00:00 2001
From: Peter Lemenkov
Date: Feb 27 2016 21:05:49 +0000
Subject: Fixed issue with nodes registration over IPv6
Signed-off-by: Peter Lemenkov
---
diff --git a/erlang.spec b/erlang.spec
index 5264f1a..81c2a53 100644
--- a/erlang.spec
+++ b/erlang.spec
@@ -16,7 +16,7 @@
Name: erlang
Version: 18.2.4
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: General-purpose programming language and runtime environment
Group: Development/Languages
@@ -2234,6 +2234,9 @@ useradd -r -g epmd -d /tmp -s /sbin/nologin \
%changelog
+* Sun Feb 28 2016 Peter Lemenkov - 18.2.4-2
+- Fixed issue with nodes registration over IPv6
+
* Tue Feb 23 2016 Peter Lemenkov - 18.2.4-1
- Ver. 18.2.4
- Build against wxGTK-3.x.y as recommended by upstream. This change won't
diff --git a/otp-0009-epmd-support-IPv6-node-registration.patch b/otp-0009-epmd-support-IPv6-node-registration.patch
index 0347c7e..b6c98b2 100644
--- a/otp-0009-epmd-support-IPv6-node-registration.patch
+++ b/otp-0009-epmd-support-IPv6-node-registration.patch
@@ -17,30 +17,22 @@ epmd ignores errors opening the socket if the protocol is not
supported. Similarly, the epmd client will fall back to IPv4 if the IPv6
socket is not available.
-The interaction between IPv4 and IPv6 sockets depends on the platform:
-
-* FreeBSD allows multiple "specific" sockets to bind the same port (such
- as 2 sockets listening to the same port on ANY and the loopback).
- Binding port 4369 to IPv4 and IPv6 sockets simulataneously is allowed.
-
-* Linux does not allow the same port to be bound by different sockets.
- Setting the IPV6_V6ONLY socket option is required.
-
-* Windows
-
- The behaviour differs depending on the version of Windows:
-
- http://msdn.microsoft.com/en-us/library/windows/desktop/bb513665(v=vs.85).aspx
-
- According to the site, sockets on Windows XP with Service Pack 1 (SP1)
- and Windows Server 2003 will only listen on either IPv4 or IPv6, so
- creating two sockets is required to service IPv4 and IPv6 traffic on
- the same port. The IPV6_V6ONLY socket option is not supported.
-
- For Windows Vista and later, a single socket can handle IPv4 and IPv6
- traffic for the same port. The IPV6_V6ONLY socket option is supported
- and is enabled for IPv6 sockets by default.
+Update the minimum supported version of Windows to Windows Vista to
+support IPv6.
+diff --git a/erts/configure.in b/erts/configure.in
+index 4fb725f..368c563 100644
+--- a/erts/configure.in
++++ b/erts/configure.in
+@@ -468,7 +468,7 @@ case $host_os in
+ win32)
+ # The ethread library requires _WIN32_WINNT of at least 0x0403.
+ # -D_WIN32_WINNT=* from CPPFLAGS is saved in ETHR_DEFS.
+- CPPFLAGS="$CPPFLAGS -D_WIN32_WINNT=0x0501 -DWINVER=0x0501"
++ CPPFLAGS="$CPPFLAGS -D_WIN32_WINNT=0x0600 -DWINVER=0x0600"
+ ;;
+ darwin*)
+ CPPFLAGS="$CPPFLAGS -D_XOPEN_SOURCE"
diff --git a/erts/doc/src/epmd.xml b/erts/doc/src/epmd.xml
index 28fcc8f..7f61804 100644
--- a/erts/doc/src/epmd.xml
@@ -55,13 +47,18 @@ index 28fcc8f..7f61804 100644
Starts the port mapper daemon
diff --git a/erts/doc/src/erl.xml b/erts/doc/src/erl.xml
-index ec4a0de..cdf8aef 100644
+index ec4a0de..9016a94 100644
--- a/erts/doc/src/erl.xml
+++ b/erts/doc/src/erl.xml
-@@ -382,6 +382,28 @@
+@@ -382,6 +382,33 @@
similar to . See
code(3).
++
++
++
Replaces the path specified in the boot script. See
++ script(4).
++
+
+
+
Specify a protocol for Erlang distribution.
@@ -80,9 +77,9 @@ index ec4a0de..cdf8aef 100644
+
+
+